В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Насяндра12
Насяндра12
07.01.2023 18:04 •  Информатика

Написать программу для вывода первых 10 чисел делящихся без остатка на 3 рандомные неповторяющиися числа (c#)

Ответ:
Наталинас
Наталинас
08.10.2020 08:18
Visual Studio 2017

using System;
class Program {
    static void Main() {
        var r = new Random();
        int[] a = new int[3];
        for (int i = 0; i < 3; i++) {
            int e = 1; bool t = true;
            while (e != 0 && t){
                e = r.Next(1, 11);
                for (int j = 0; j < 3; j++)
                    if (e == a[j]) { t = true; break; } else t = false;
            }
            a[i] = e;
            Console.Write(a[i] + " ");
        }
        Console.WriteLine();
        int[] m = new int[10]; int b = 0;
        
        for (int i = 0; i < 10; i++) {
            while (b % a[0] != 0 || b % a[1] != 0 || b % a[2] != 0) b++; 
            m[i] = b;
            b++;
            Console.Write(m[i]+" ");
        }
        Console.Read();
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?