В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
slava90100
slava90100
24.07.2020 16:23 •  Информатика

Написать программу для оценки ожидания и дисперсии в паскаль

Ответ:
Matveystori
Matveystori
08.10.2020 07:55
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var x:=new real[] (-3.0,-7.0,0.0);
  var p:=new real[] (0.1,0.2,0.7);
  var Mx:=x.Zip(p,(a,b)->a*b).Sum;
  var Mx2:=x.Zip(p,(a,b)->a*a*b).Sum;
  var Dx:=Mx2-Sqr(Mx);
  Writeln('Математическое ожидание ',Mx,', дисперсия ',Dx)
end.

Результат
Математическое ожидание -1.7, дисперсия 7.81
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?