Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
hackerprincess
07.02.2020 06:38 •
Информатика
Решить, дано двумерный массив целых чисел. вычислить сумму всех отрицательных элементов массива и добавить его к третьему элементу массива во втором столбце решить с функциями с++
Ответ:
Reginka24082007
08.10.2020 07:08
#include <iostream>
#include <array>
#include <random>
using namespace std;
mt19937 gen { random_device()() };
uniform_int_distribution<> uid(-20, 20);
constexpr size_t N = 5;
int main()
{
int sum = 0;
array<array<int, N>, N> a;
for (auto &i : a) {
for (auto &j : i) {
if ((j = uid(gen)) < 0) {
sum += j;
}
cout << j << "\t";
}
cout << endl;
}
cout << endl;
a[1][2] += sum;
for (const auto &i : a) {
for (const auto &j : i) {
cout << j << "\t";
}
cout << endl;
}
cout << "Sum: " << sum << endl;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ромб13
20.05.2021 21:35
Укажите количество ячеек в диапазоне (с объяснениями) a)a1: b5 б)g23: g153 в)b11: d13...
irkaShpagina
25.03.2021 01:51
составить слова используя А=000,М=100,О=010,Л=001,К=110,И=112,Р=113,Б=111. Я пока составил Мама=100000100000 Молоко=100010001010110010 Кира=110112113000...
katrinzeta18
19.04.2020 15:10
мне задание по информатике...
Vladtop11234
25.04.2020 08:44
Всистеме счисления с основанием n запись числа 87 оканчивается на 2 и содержит не более двух цифр. чему равно число n? если у есть несколько решений, выберите наименьшее....
Arslanisyan
25.04.2020 08:44
Дано дійсне число в, не користуючись арифметичними операціями крім множиннч одержати в5 за 3 операції, при тому, що в=2...
Альмира2007
10.08.2021 19:29
Составьте монолог на тему «для чего живёт человек»...
85396ira
05.11.2021 22:55
Розв яжіть рівняння (х-2)-5(х-3)(х+3)+4(х-1)(х+4)=1...
анарка3
01.12.2022 03:16
Сравните на глаз отрезки AB и CD(рис. 33). Проверьте свой вывод измерения...
АлинаЛог
18.04.2022 19:05
Профессии будущего. Правописание окончаний. Урок 1 Укажи неправильные объяснения написания слова.Верных ответов: 2Постелем скатерть – в окончании глагола I спр. в форме 1-ого...
ruslan5632
18.04.2022 19:05
Выпишите из текста словосочетания, которые относятся к описанию де- душки, и сравните со словами, характеризующими сына с женой и вну-ка. Заполните таблицу. 8 класс...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <array>
#include <random>
using namespace std;
mt19937 gen { random_device()() };
uniform_int_distribution<> uid(-20, 20);
constexpr size_t N = 5;
int main()
{
int sum = 0;
array<array<int, N>, N> a;
for (auto &i : a) {
for (auto &j : i) {
if ((j = uid(gen)) < 0) {
sum += j;
}
cout << j << "\t";
}
cout << endl;
}
cout << endl;
a[1][2] += sum;
for (const auto &i : a) {
for (const auto &j : i) {
cout << j << "\t";
}
cout << endl;
}
cout << "Sum: " << sum << endl;
}