В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
julija1245
julija1245
08.09.2020 17:33 •  Информатика

Дан массив целых чисел из n элементов сформированный случайным образом. определить, сколько в нем чисел кратных 7 написать программу в паскаль

Ответ:
greentyler451
greentyler451
08.10.2020 07:02
Var
  a, k, n, i, sum: integer;
 
begin
  read(n, k);
  for i := 1 to n do
  begin
    read(a);
    if a mod k = 0 then sum := sum + a;
  end;
  writeln(sum) ;
end.

где k - заданное число которому должны быть кратны элементы массива
n - кол-во элементов массива
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?