В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Dan0304
Dan0304
14.07.2022 00:25 •  Информатика

Вданном массиве чисел найдите среднее арифметическое положительных элементов массива. составить программу для pascal abc

Ответ:
SashaPoznavatel
SashaPoznavatel
08.10.2020 06:42
var    
     arr : array[1..99] of integer;
     N, s, k : integer;
begin
    read(N);
    for var i := 1 to N do begin
        arr[i] := random(-10, 10);
        writeln(arr[i]);
        if arr[i] > 0 then begin
            s += arr[i];
            k += 1;
        end
    end;
    writeln(s/k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?