Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Alya12311
19.05.2022 20:23 •
Информатика
Заполнить массив случайными числами от 1 до 50 и вывести количество чётных и нечётных чисел в массиве.
Ответ:
Robingood135
08.10.2020 06:19
PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),1,50); a.Println;
var k:=a.Where(t->t.IsOdd).Count;
Writeln('Четных ',a.Length-k,', нечетных ',k)
end.
Пример
n= 17
45 42 36 34 47 15 3 16 47 35 14 13 3 45 28 31 16
Четных 7, нечетных 10
0,0
(0 оценок)
Популярные вопросы: Информатика
Ева433
15.07.2022 12:18
Для передачи по каналу связи сообщения, состоящего только из символов k - 101, h - 10, o -11. через канал связи передается сообщение окно. закодируйте сообщение данным...
DashaKarg3
14.06.2021 19:37
Написать программу на языке паскаль , которая вводит из пульта оператора значения d,c,a,h, и выводит значения b ( 2)...
Прммрррр
15.07.2022 12:18
Сколько секунд минимум потребуется модему, сообщения со скоростью 28800 бит/с , чтобы передать 100 страниц текста в 30 строк по 60 символов каждая, при условии что...
Donisimys000000
09.08.2022 17:18
Кзаписи натурального числа в восьмеричной системе счисления справа приписали два нуля. во сколько раз увеличилось число? ответ запишите в десятичной системе счисления....
BlackPorshe2356
09.08.2022 17:18
Многократное размещение однотипной информации повторяющейся фразы символов букв слов одинаковий гравических файлов...
guara3
09.08.2022 17:18
Дано вещественное число,цена 1кг. конфет,вывести стоимость от 1 до 10...
NORTHVIRUS
03.08.2021 11:24
Вычислить сумму первых n слагаемых : s= 1+3\2+5\3+7\4=9\5+...
FSoxGy
03.08.2021 11:24
Пож)) 1) почему при уменьшении и увеличении растрового изображения ухудшается его качество? 2) в чем состоят основные различия между форматами растровых графических...
bua20
03.08.2021 11:24
125-в двоичной системе счисления,в восьмеричной десятеричной системе счисления....
sxpidxoznitsxa
03.08.2021 11:24
1каким образом выражаются отношения между объектами? назовите имя отношения в каждом предложении. какое имя можно будет дать отношению, если имена объектов в предложении...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),1,50); a.Println;
var k:=a.Where(t->t.IsOdd).Count;
Writeln('Четных ',a.Length-k,', нечетных ',k)
end.
Пример
n= 17
45 42 36 34 47 15 3 16 47 35 14 13 3 45 28 31 16
Четных 7, нечетных 10