В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yliuagulian
yliuagulian
10.01.2020 20:37 •  Информатика

Напишите программу вычисления суммы отрицательных значений функции q(w)=31w+31 на отрезке [a; b] с шагом h

Ответ:
Чевапчичи
Чевапчичи
08.10.2020 05:56
PascalABC.NET:

Var
  Q,w, a,b,h, S: real;
Begin
  WriteLn('Q(w) = 31w+31');
  Write('a = ');ReadLn(a);
  Write('b = ');ReadLn(b);
  Write('h = ');ReadLn(h);
  S := 0;
  w := a;
  if (a < b) then
  begin
    if (h < 0) then exit;
  end
  else if (a > b) then
    if (h > 0) then exit;
 
  While (w <= b) do
  begin
    Q := 31*w+31;
    if (Q < 0 ) then
      S := S + Q;
    w := w + h;
  end;
  WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?