Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
water12
27.03.2022 13:36 •
Информатика
Вывести квадраты чисел от 1 до n. в паскале написать программу (не используя for)
Ответ:
EZno
08.10.2020 05:40
1)
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
Range(1,n).Select(i->i*i).Println;
end.
Пример:
n = 5
1 4 9 16 25
2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i<n) do
begin
i:=i+1;
write(i*i,' ');
end;
end.
3)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
repeat
i:=i+1;
write(i*i,' ');
until i=n;
end.
Пример:
N = 5
1 4 9 16 25
0,0
(0 оценок)
Популярные вопросы: Информатика
s2702e
30.09.2022 06:33
В каком виде выглядят словесное описание алгоритма?...
песок3
06.09.2021 21:59
Если в текстовом процессоре создать таблицу, затем эту таблицу выделить полностью и нажать кнопку на панели форматирования, что получится в результате? 1 И таблица раздвинется...
SashaSvey
14.01.2022 11:55
На CD- диск можно записать большим количеством программзаписать текстовую, графическую, звуковую информациюИграть на двух компьютерах...
gal12
06.04.2023 16:58
Нурбол прочитал роман Путь Абая . В один день он состоит из 20 страниц, одна страница-из 30 строк, одна строка-из 50 символов. Сколько информации Нурбол принял за один деньбайт,...
kocherovavika2005
10.01.2020 00:07
Разрешение монитора 1920х1080 пикселей, глубина цвета - 24 бита. сколько потребуется памяти для хранения скриншота с этого монитора? ответ дать в кбайтах....
N1ke1N1kev1ch
19.03.2020 15:29
Синформатикой вас нужно через python...
PolinaChery04
23.01.2023 17:08
A»: напишите процедуру, которая принимает параметр –натуральное число n – и выводит на экран линию из nсимволов – . (python)пример: введите n: 10...
Lerka0tarelka
09.05.2020 01:28
Какие ученые сыграли важную роль в развитии устройств вычислительной техник...
alina28042002
15.01.2022 11:53
Сообщение состоит из 20 символов символьный буквами алфавита, и 64. рассчитайте объем информационного сообщения...
Dimka14228
06.02.2020 07:26
3 Read paragraph 2 again. Label the diagram 1-4....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
Range(1,n).Select(i->i*i).Println;
end.
Пример:
n = 5
1 4 9 16 25
2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i<n) do
begin
i:=i+1;
write(i*i,' ');
end;
end.
3)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
repeat
i:=i+1;
write(i*i,' ');
until i=n;
end.
Пример:
N = 5
1 4 9 16 25