В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
lololol707lollol
lololol707lollol
16.05.2023 10:29 •  Информатика

Составить блок-схему и написать программу для проверки того, что в сумма цифр некоторого числа равна 10

Ответ:
Gusein123
Gusein123
08.10.2020 05:31
Замечание: предполагается, что вводятся натуральные числа.
Блок-схема - в прилагаемом файле.
var a,s:integer;
begin
readln(a);
s:=0;
while a>0 do
 begin
 s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('s = ',s);
if s=10 then writeln('s = 10')
else writeln('s <> 10');
end.

Пример:
527
s = 14
s <> 10
Составить блок-схему и написать программу для проверки того, что в сумма цифр некоторого числа равна
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?