В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Nastyusha2aa5
Nastyusha2aa5
29.12.2021 02:32 •  Информатика

Составить программу нахождения всех трехзначных чисел, таких, что сумма цифр равна а, а само число делится на в (а и в вводятся с клавиатуры).

Ответ:
joni200428
joni200428
08.10.2020 04:58
Var a,b,s,q,w,e:Integer;
begin
Read(a,b);
for s:= 100 to 999 do
begin
q:= s div 100;
w:= s div 10 mod 10;
e:= s mod 10;
if (q+w+e=a) and(s mod b = 0) then
WriteLn(s);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?