В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
cawa1303
cawa1303
21.04.2020 16:07 •  Информатика

(99 ! ) python напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов.если в массиве нет элементов с чётными положительными значениями,нужно вывести сообщение об этом.

Ответ:
vgjfgadg
vgjfgadg
21.08.2020 12:28
mas = [int(i) for i in input('Введите массив : ').split()]
flag = 0
for i in mas:
    if i%2 == 0:
        max = min = i
        flag = 1
        break
if flag == 0:
    print('Четных нет!')
    exit()
for i in mas:
    if i%2 == 0 and i > max:
        max = i
    if i%2 == 0 and i < min:
        min = i
print(max,min) 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?