В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Aruzhan5555
Aruzhan5555
08.05.2022 12:39 •  Информатика

Написать программу которая проверяет -является ли сумма цифр заданного трехзначного числа четным числом

Ответ:
OxanchikG
OxanchikG
21.08.2020 12:26
C++
size_t sum(size_t val)
{
     static size_t temp = 0;
     if (val > 0) {
         sum(val / 10);
         temp += val % 10;
     }
     return temp;
}  
int main()
{
     (sum(123) % 2) == 0 ? cout << "True" : cout << "False";  
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?