Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
serotettonika
23.07.2020 12:47 •
Информатика
Напишите программу, которая заполняет массив случайными числами на отрезке [2; 10] и считает отдельно количество четных и нечетных элементов
Ответ:
saaaasss01
01.09.2020 19:17
Const n=10;
var a:array[1..n] of integer;
k,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(9)+2;
write(a[i],' ');
end;
writeln;
k:=0;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln('Четных: ',k,' нечётных: ',n-k);
end.
Пример:
2 2 4 7 9 10 9 4 5 4
Четных: 6 нечётных: 4
0,0
(0 оценок)
Популярные вопросы: Информатика
Nastya8laif
25.01.2022 21:20
Значение арифметического выражения: 9^7 + 3^12 – 9 – записали в системе счисления с основанием 3. сколько цифр «2» содержится в этой записи?...
yfryjkngttyufddvn
26.02.2023 14:06
Эссе на тему информационные комуникоционные тегнологии...
arystan307
03.11.2022 06:47
Запишите основные этапы создания презентации...
julianna19
11.09.2021 23:12
Составьте программу pascal для 2a -7b + c нужно...
leomax2
11.07.2021 21:50
Какому деситичному числу соответствует число 101111 и 2 снизу...
danilsartakov
02.09.2022 19:41
Даны 4 числа. нужно найти наибольшее и наименьшее значение этих чисел(блок-схема). с объяснениями, позязя т.т...
supernogai
24.01.2022 04:21
Царь и рубашка. один царь был болен и сказал: — половину царства тому, кто меня вылечит. тогда собрались все мудрецы и стали судить, как царя вылечить. никто не знал....
Yabloco4
18.04.2022 20:02
Назовите родовое поместье и.с. тургенева. 5. в какой сборник входит рассказ и.с. тургенева «бирюк»? 6. что обозначает слово «бирюк»? 7. почему бирюк все же отпустил крестьянина?...
AlexMYP
18.04.2022 20:02
Через вершину конуса проведено площину під кутом альфа до площини основи. ця площина перетинає основу конуса по хорді, яку видно з центра його основи під кутом бета. радіус...
ainashka1919
18.04.2022 20:02
Определите высоту, на которой кинетическая энергия тела, брошенного вертикально вверх сос коростью 30м/с, составляет 1/2 часть потенциальной а)15м б)20м в)30м г)45м...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:array[1..n] of integer;
k,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(9)+2;
write(a[i],' ');
end;
writeln;
k:=0;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln('Четных: ',k,' нечётных: ',n-k);
end.
Пример:
2 2 4 7 9 10 9 4 5 4
Четных: 6 нечётных: 4