Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
KSUmaUYouTobe
08.04.2022 15:54 •
Информатика
Написать программу на языке pascal которая вводит первых 50 членов арифметической прогрессии. .
Ответ:
кхммммм
08.10.2020 03:54
Var a: array [1..50] of integer ;
d:integer;
begin
write ('Введите первый член a1 = ');
read(a[1]);
write('Разность d = ');
read(d);
writeln(a[1]);
for var i:=2 to 50 do begin
a[i]:=a[1]+d*(i-1);
writeln(a[i]);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nastia311
16.03.2021 20:56
Дано описание одного из законов алгебры логики. Выбери верный ответ. Отрицание дизъюнкции есть конъюнкция отрицаний. Отрицание конъюнкции есть дизъюнкция отрицаний. 1.закон...
Sofiamarfiya
04.07.2020 23:31
1. Укажите все верные ответы. Какие информационные модели можно выделить, если за основу взять предметную область?Экологические моделиДинамические моделиСтатические моделиСмешанные...
Scorpionoid
13.08.2020 06:39
Дана непустая последовательность символов. постройте и напечатайте множество, элементами которого являются встречающиеся в последовательности цифры от “0” до “9...
beka9867
17.12.2022 15:22
Создать массив а из десяти целых чисел, принадлежащих промежутку [-10; 20). вывести полученный массив на экран. подсчитать сумму элементов массива, значение которых превышает...
Жан041
17.12.2022 15:22
Нужно описать,каждую строчку этой программы program p1; type mytype=set of char; var m,n,g: mytype; w,s: string; i,k: integer; begin m: =[ a .. f ]; n: =[ x .. z ]; g: =m+n;...
antoshkaromanov
17.12.2022 15:22
Воспользовавшись правилом триад и тетрад, перевести из двоичной системы счисления в восьмеричную и шестнадцатеричную системы счисления, следующие число: 1010111101...
deadraccoon20
19.02.2022 04:03
Как классифицируются субъекты информационной деятельности? ...
DanielB2008
03.09.2021 08:19
Вес одного символа в некотором алфавите равен 5 бит. Чему равна мощность этого алфавита?...
lidok575
16.07.2022 17:45
Pascal: Занятия в школе начинаются в 8-30. Урок длится 45 минут, перерывы между уроками – 10 минут. Ввести номер урока и вывести время его окончания. Пример: Введите номер...
VoinBogov
08.05.2021 04:59
Дано отрицательное число в десятичной системе счисления: -38(10). Представьте данное число в двоичной системе счисления. буду благодарна за ответ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
d:integer;
begin
write ('Введите первый член a1 = ');
read(a[1]);
write('Разность d = ');
read(d);
writeln(a[1]);
for var i:=2 to 50 do begin
a[i]:=a[1]+d*(i-1);
writeln(a[i]);
end;
end.