В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
toalexalfaa
toalexalfaa
11.04.2022 01:39 •  Информатика

Составьте программу, для подсчета дней, месяцев с температурой 15градусов, массив в программе сформировать с клавиатуры. pasckal abc.

Ответ:
nadinnik4
nadinnik4
08.10.2020 03:21
const
    handsfree = false;
    nmax = 31;
    random_min = -20;
    random_max = 30;

var
    a: array[1..nmax] of real;
    i, n, j: integer;
    k: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(nmax - 5) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(random_max - random_min) + random_min;
            write(a[i], ' ');
        end
        else
            readln(a[i]);
    end;
    writeln();
    
    {подсчет элементов}
    k := 0;
    for i := 1 to n do
        if a[i] = 15 then
            k := k + 1;
    writeln('quantity = ', k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?