В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Dan363
Dan363
06.04.2021 01:06 •  Информатика

Составить программу, которая запрашивая вес покупки в граммах переводило в кг

Ответ:
Tennisboy
Tennisboy
10.09.2020 12:24
Program z1;
var a,b:real;    
f:longint;
begin
writeln('Ââåäèòå Г¬Г*Г±Г±Гі Гў ГЄГЈ:');
read(a);
writeln('Ââåäèòå åäèГ*ГЁГ¶Гі âûâîäГ*:');
writeln('1 - ìèëëèãðГ*ìì');
writeln('2 - ГЈГ°Г*ìì');
writeln('3 - êèëîãðГ*ìì');
writeln('4 - Г¶ГҐГ*ГІГ*ГҐГ°');
writeln('5 - ГІГ®Г*Г*Г*');
read(f); if (f<1) or (f>6) then begin                        writeln('Ïîâòîðèòå ââîä');                        
read(f);                        
end;
if f=1 then begin            
b:=a*1000000;            
write(a,' ГЄГЈ=',' ',b,' ','ìèëëèãðГ*ìì');            
end;
if f=2 then begin            
b:=a*1000;            
write(a,' ГЄГЈ=',' ',b,' ','ГЈГ°Г*ìì');            
end; if f=3 then begin            
b:=a;            
write(a,' ГЄГЈ =',' ',b,' ','êèëîãðГ*ìì');            
end; if f=4 then begin            
b:=a/100;            
write(a,' ГЄГЈ=',' ',b,' ','Г¶ГҐГ*òðîâ');            
end;
if f=5 then begin            
b:=a/1000;            
write(a,' ГЄГЈ=',' ',b,' ','ГІГ®Г*Г*');            
end;
writeln('ÏðîãðГ*ììГ* Г§Г*âåðøåГ*Г*');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?