В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
teoqyeowo
teoqyeowo
28.04.2023 16:59 •  Информатика

Даны три целых числа. определите, сколько среди них . программа должна вывести одно из чисел: ■ 3 – если все ; ■ 2 – если два совпадает; ■ 0 – если все числа различны.

Ответ:
yuikire
yuikire
26.08.2020 23:29
Var a,b,c:integer;
begin
readln(a,b,c);
if (a=b)and(b=c) then writeln(3)
 else if (a=b)or(b=c)or(a=c) then writeln(2)
  else writeln(0);
end.

Пример:
5 7 5
2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?