В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
kirillm3
kirillm3
13.05.2021 11:26 •  Информатика

1) напишите программу, которая считает количество чётных цифр введённого числа. 2) напишите программу, которая считает сумму цифр введённого числа. все для c++ хорошо если через цикл с условиями

Ответ:
onealoner13
onealoner13
08.10.2020 02:29
#include <iostream>
using namespace std;
int main()
{
     int val = 253;
     int sum = 0;
     int tmp = 0;
     int c   = 0;
     while (val) {
         tmp = val % 10;
         if (!(tmp % 2)) {
             ++c;
         }
         sum += tmp;
         val /= 10;
     }
     cout << "Res = " << sum << endl;
     cout << "Count = " << c << endl;
     system("pause");
     return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?