Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
busilagalina
18.02.2023 21:16 •
Информатика
Составить программу s треугольника по формуле герона, если известны все его стороны
Ответ:
1luvash
08.10.2020 02:28
Begin
var a, b, c, d: real;
WriteLN('Сторона A:');
ReadLN(a);
WriteLN('Сторона B:');
ReadLN(b);
WriteLN('Сторона C:');
ReadLN(c);
d := a+b+c;
WriteLN('P=', d);
WriteLN('Если P=', d, ' то p = ', d/2);
WriteLN('По формуле герона Под корнем(p-a*p-b*p-c)', sqrt((d-a)*(d-b)*(d-c)));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Hause1
19.07.2021 18:17
Программа с широкими возможностями обработки теста (Вставка гиперссылок, диаграмм, рисунков называется текстовый... ...
АринаВарданян
04.04.2021 17:45
До якого типу відноситься змінна f = Vasya ...
СлаваТрегубкин
14.10.2020 11:03
3. Що таке коментар у проекті? Як можна коментар включити до тексту проекту?...
мдсши
29.06.2020 18:32
3. Что будет выведено на экран в результате работы программы: a = Trueb = Falseif a and b: print(1)else: print(2) ...
bockovickof
09.02.2020 03:39
у lazarus цикл з лічильником описується оператором1. FOR2.REPEAT3.TO...
artem24322004
13.11.2020 17:31
.Надо написать выражение на Pythone...
flexELITE3
14.09.2022 08:46
Впиши координаты указанной точки....
полина10092003
17.03.2020 21:00
1. Черепашке был дан для исполнения следующий алгоритм: Повтори 6 [Вперёд 80 Направо 60]. Какая фигура появится на экране?1) правильный пятиугольник2) правильный треугольник3)...
lailylaily
14.01.2020 20:40
1. Черепашке был дан для исполнения следующий алгоритм: Повтори 6 [Вперёд 80 Направо 90]. Какая фигура появится на экране?1) правильный четырехугольник2) правильный треугольник3)...
2005Dasha0305
26.12.2022 02:43
1. Исполнитель КУЗНЕЧИК живёт на числовой оси. Начальное положение КУЗНЕЧИКА – точка 0. Система команд Кузнечика:Вперед 5 – Кузнечик прыгает вперёд на 5 единиц,Назад 2...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a, b, c, d: real;
WriteLN('Сторона A:');
ReadLN(a);
WriteLN('Сторона B:');
ReadLN(b);
WriteLN('Сторона C:');
ReadLN(c);
d := a+b+c;
WriteLN('P=', d);
WriteLN('Если P=', d, ' то p = ', d/2);
WriteLN('По формуле герона Под корнем(p-a*p-b*p-c)', sqrt((d-a)*(d-b)*(d-c)));
end.