В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Apelsin2403
Apelsin2403
11.10.2021 15:41 •  Информатика

С++ напишите программу, которая выводит на экран все цифры числа, начиная с первой. допустим, вводишь 123, а программа выводит 1 2 3.

Ответ:
RaSyL111
RaSyL111
08.10.2020 02:00
Один из простых методов.
#include <iostream>
void digits(const unsigned &val)
{
    if (val) {
        std::cout << (digits(val / 10), val % 10) << "  ";
    }
}
int main()
{
    digits(123);
    return 0;
}
0,0(0 оценок)
Ответ:
Asuacom
Asuacom
08.10.2020 02:00
#include <iostream>
#include <stack>

using namespace std;

void digits(int *num);

int main()
{
    int num;
    cin >> num;
    void(*ptr)(int *num);
    ptr = digits;
    (*ptr)(&num);
    return 0;
}
void digits(int *num)
{
    stack<short int> stack;
    while(*num>0)
    {
        stack.push(*num % 10);
        *num /= 10;
    }
    while(!stack.empty())
    {
        cout << stack.top() << " ";
        stack.pop();
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?