В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DashaZhur1752
DashaZhur1752
27.05.2021 12:20 •  Информатика

Составить программу, которая выводит на экран названия не менее трех городов

Ответ:
zologiru
zologiru
21.08.2020 11:38
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:array[1..3] of string;
  var l:array[1..3] of integer;
  for var i:=1 to 3 do begin
    Write('Город ',i,': '); Readln(a[i]);
    l[i]:=Length(a[i])
    end;
  var imin:=1; var imax:=1;
  for var i:=2 to 3 do begin
    if l[i]<l[imin] then imin:=i;
    if l[i]>l[imax] then imax:=i
    end;
  Writeln('Самое длинное название- ',a[imax]);
  Writeln('Самое короткое название- ',a[imin])
end.

Тестовое решение
Город 1: Москва
Город 2: Минск
Город 3: Киев
Самое длинное название- Москва
Самое короткое название- Киев
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?