В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
maksitron
maksitron
13.06.2022 17:58 •  Информатика

Написать программу в lazarus на языке pascal. 1)известна гипотенуза и прилежащий угол прямоугольного треугольника. найти площадь треугольника. 2)задана последовательность m случайных натуральных чисел. вычислить количество натуральных чисел, кратных трем и не превышающих заданное n. 3)заменить в строке все цифры на пробел. вывести количество замен.

Ответ:
SonyaNik228
SonyaNik228
08.10.2020 01:51
Попробуй так, но это по сторонам и углу,
program triangle;
var a,b,s,k: real;
procedure triang (a,b,k: real; var s: real);
begin
s:= 0.5 * a * b * sin(k);
end;
begin
write ('Введите стороны a и b через пробел: ');
readln (a,b);
write ('Введите угол: ');
readln (k);
triang (a,b,k,s);
WriteLn('Площадь = ',s:5:2);
end.
Это первое задание.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?