В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
KriStiNaTim03
KriStiNaTim03
02.03.2022 09:49 •  Информатика

Составить программу: дан массив из n элементов, посчитать произведение положительных элементов ..

Ответ:
MiklJackson
MiklJackson
08.10.2020 01:48
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Writeln('Произведение положительных элементов равно ',
      a.Where(x->x>0).Aggregate(BigInteger(1),(p,q)->p*q))
end.

Составить программу: дан массив из n элементов, посчитать произведение положительных элементов ..
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?