В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Victoriahamidul
Victoriahamidul
15.12.2020 23:53 •  Информатика

Pascal abc.net нужна ! 8) даны натуральное число n и вещественные числа a1, a2, …, an. найти количество вещественных чисел, которые больше своих соседей, т. е. предшествующего и последующего. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n вещественных чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество вещественных чисел, которые больше своих соседей. пример исходные данные 9 3 -1 12 5 -17 5 2 15 -5 результат 3 9) даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai, равных между собой. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai, равных между собой. пример исходные данные 9 3 -1 -1 5 -17 5 2 2 -5 результат 2 10. даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai , являющихся четными числами. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai , являющихся четными числами. пример исходные данные 10 3 0 4 5 -17 5 2 14 -5 результат 2

Ответ:
8)
// PascalABC.NET 3.3

begin
  var n:=ReadInteger();
  var a:=ReadArrReal(n);
  var k:=a.Where((x,i)->(i>0)and(i<n-1)and
    (a.ElementAt(i)>a.ElementAt(i-1))and(a.ElementAt(i)>a.ElementAt(i+1))).Count;
  Writeln(k);
end.

Пример:
9
3 -1 12 5 -17 5 2 15 -5
3

9)
begin
  var n:=ReadInteger();
  var a:=ReadArrInteger(n);
  var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i)=a.ElementAt(i+1))).Count;
  Writeln(k);
end.

Пример:
9
3 -1 -1 5 -17 5 2 2 -5
2

10)
begin
  var n:=ReadInteger();
  var a:=ReadArrInteger(n);
  var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i) mod 2=0)and(a.ElementAt(i+1) mod 2=0)).Count;
  Writeln(k);
end.

Пример:
10
3 0 4 5 -17 5 2 14 -5
2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?