В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу в паскале, в которой нужно ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

Ответ:
MrDeder
MrDeder
08.10.2020 00:40
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите натуральное число');
  var r:=n.ToString.Pairwise.Where(t->t[0]=t[1]).Any;
  if r then Writeln('Есть две одинаковые цифры, стоящие рядом')
  else  Writeln('Нет двух одинаковых цифр, стоящие рядом')
end.

Пример
Введите натуральное число 245005
Есть две одинаковые цифры, стоящие рядом
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?