В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
refwqef
refwqef
22.02.2020 22:53 •  Информатика

Дано 6 цифр. вывести есть ли среди них повторяющиеся. написать программу pascal abc

Ответ:
русскийязык150
русскийязык150
08.10.2020 00:26
Var s: set of integer;
    i,a,k: integer;
begin
  s:=[]; k:=0;
  write('введите 6 чисел через пробел  ');
  for i:=1 to 6 do
  begin
    read(a);
    if a in s then inc(k);    
    s:=s+[a];
  end;
  if k>0 then writeln('есть повторяющиеся')
  else writeln('нет повторяющихся');
end.

введите 6 чисел через пробел  10 12 15 19 17 15
есть повторяющиеся

введите 6 чисел через пробел  17 19 21 13 14 15
нет повторяющихся
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?