В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Verabogomaz
Verabogomaz
14.07.2020 11:00 •  Информатика

Написать программу, . напишите программу, которая находит сумму двухзначных нечетных чисел. последовательность чисел заканчивается числом 0.

Ответ:
Yarik346
Yarik346
08.10.2020 00:15
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t<>0)
      .Where(t->t.IsOdd and t.InRange(10,99)).Sum.Println
end.
0,0(0 оценок)
Ответ:
MasterGameTV1
MasterGameTV1
08.10.2020 00:15
Program n1;
var a,sum: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if (a>9) and (a<100) and (a mod 2<>0) then sum:=sum+a;
readln(a);
end;
write(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?