В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу в pascal, среди 8 положительных чисел найти такое, которое имеет наибольшую сумму цифр, используя функцию

Ответ:
egorovaesya
egorovaesya
07.10.2020 23:50
Var a,i,s,max,amax:integer;
function sum(n:integer):integer;
var s:integer;
begin
s:=0;
while n<>0 do
 begin
 s:=s+n mod 10;
 n:=n div 10;
 end;
sum:=s;
end;
begin
max:=0;
for i:=1 to 8 do
 begin
 write('a = ');
 readln(a);
 s:=sum(a);
 if s>max then begin max:=s; amax:=a; end;
 end;
writeln('В числе ',amax,'  максимальная сумма цифр = ',max);
end.

Пример:
a = 405a = 120
a = 309
a = 671
a = 456
a = 215
a = 751
a =321
В числе 456 максимальная сумма цифр = 15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?