В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
irinawinchester666
irinawinchester666
29.10.2022 05:38 •  Информатика

Напишите программу по формуле s=1+x/1+x^2/2+x^3/3++x^n/n

Ответ:
AkiraK666
AkiraK666
07.10.2020 23:32
PASCAL:
var
   S, x: real;
   i, n: integer;

begin
readln(x, n);
S := 1;
for i := 1 to n do
   S := S + power(x, i) / i;

writeln(S);
end.

C:
#include <stdio.h>
#include <math.h>
#include <conio.h>

int main() 
{
   float S = 1,
           x = 0,
           n = 0;
   scanf("%f %f", &x, &n);
   
   for (int i = 1; i <= n; i++)
      S = S + pow(x, i) / i;
   
   printf("%f", S);
   getch();
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?