В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lenusja272
lenusja272
02.05.2022 07:07 •  Информатика

Известно, что 1 число месяца-день недели среда. составить программу, которая после ввода любого числа в этом месяце выдаёт какой это день недели

Ответ:
Спаси60
Спаси60
07.10.2020 23:31
Var d, n: integer;
begin
write('Номер дня недели первого числа месяца (1..7): ');
readln(d);
write('День месяца (1..31): ');
readln(n);
write('Это ');
case (n + d - 2) mod 7 of
0: write('понедельник');
1: write('вторник');
2: write('среда');
3: write('четверг');
4: write('пятница');
5: write('суббота');
6: write('воскресение')
end;
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?