В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
кузя177
кузя177
04.10.2022 18:35 •  Информатика

Напишите программу нахождения из большей из двух чисел. ( 99 ) *например* program n_10 var y, a, b, c : integer; begin writeln ('нахождение наибольшей из трёх величин'); write ('введите a,b,c> > ') readln (a,b,c); y: =a; и так-далее.

Ответ:
yuliyamusatova1
yuliyamusatova1
07.10.2020 23:17
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('Введите два числа:');
  if a>b then Writeln('Первое число больше')
  else
    if b>a then Writeln('Второе число больше')
    else Writeln('Числа равны')
end.

Пример
Введите два числа: 25 24.95
Первое число больше
0,0(0 оценок)
Ответ:
darkmusson
darkmusson
07.10.2020 23:17
Program asd;
uses crt;
var a,b,c : integer;
begin
c:=0;
writeln('Введите первое число');
readln (a);
writeln('Введите второе число');
readln(b);
if a<b then c:=a else c:=b;
writeln(c);
end.
0,0(0 оценок)
Ответ:
Bonga1337
Bonga1337
28.01.2024 12:47
Хорошо, я готов выступить в роли школьного учителя и помочь тебе решить эту задачу.

Программа для нахождения большего из двух чисел будет выглядеть следующим образом:
```
program findGreaterNumber;
var
a, b: integer;

begin
// Выводим на экран сообщение с просьбой ввести числа
writeln('Введите два числа: ');

// Считываем числа, введенные пользователем
readln(a, b);

// Сравниваем числа и выводим наибольшее
if a > b then
writeln('Наибольшее число: ', a)
else if b > a then
writeln('Наибольшее число: ', b)
else
writeln('Числа равны');
end.
```

Теперь рассмотрим эту программу более подробно:
1. `program findGreaterNumber;` - объявление программы с названием "findGreaterNumber". Это позволяет нам идентифицировать программу при выполнении.

2. `var a, b: integer;` - объявление переменных `a` и `b`. Мы используем тип данных `integer`, чтобы работать с целыми числами.

3. `begin` - начало основной части программы.

4. `writeln('Введите два числа: ');` - выводим на экран сообщение с просьбой ввести два числа.

5. `readln(a, b);` - считываем числа, которые пользователь вводит с клавиатуры.

6. `if a > b then` - если число `a` больше числа `b`, выполняется следующая команда.

7. `writeln('Наибольшее число: ', a)` - выводим на экран сообщение о том, что число `а` является наибольшим.

8. `else if b > a then` - если число `b` больше числа `a`, выполняется следующая команда.

9. `writeln('Наибольшее число: ', b)` - выводим на экран сообщение о том, что число `b` является наибольшим.

10. `else` - если ни одно из условий вверху не выполнилось, выполняется следующая команда.

11. `writeln('Числа равны');` - выводим на экран сообщение о том, что числа равны.

12. `end.` - конец основной части программы.

Теперь давайте рассмотрим пример использования этой программы с конкретными числами. Допустим, мы хотим найти наибольшее число из 15 и 23:
```
Введите два числа:
15 23
Наибольшее число: 23
```

В этом примере программа сравнивает числа 15 и 23 и выводит сообщение о том, что наибольшее число - 23.

Надеюсь, теперь тебе понятно, как работает эта программа и как она решает задачу нахождения бо...
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?