В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vladyslav2523
vladyslav2523
21.09.2021 01:55 •  Информатика

Написать программу на языке pascalabc, которая умеет выполнять арифметические действия с 5 разными числами и выводит промежуточные и итоговый результаты. пример работы программы: введите первое число: 4 выберите первое действие (a) сложить, b) вычесть, c) умножить, d) разделить): a введите второе число: 8 первая операция: 4+8=12 введите второе действие (a) сложить, b) вычесть, c) умножить, d) разделить): c введите третье число: 3 вторая операция: 12*3=26 так до пятого числа и 5 операции

Ответ:
1Продавец1
1Продавец1
07.10.2020 23:09
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=Arr('первое', 'второе','третье','четвертое','пятое');
  var p,r:real;
  var c:char;
  Write('Введите первое число: '); Readln(r);
  for var i:=0 to 3 do begin
    Write('Выберите ',s[i], ' действие (a) сложить, b) вычесть,');
    Write('c) умножить, d) разделить): '); Readln(c);
    Write('Введите ',s[i+1],' число: '); Readln(p);
    case c of
    'a':r+=p;
    'b':r-=p;
    'c':r*=p;
    'd':r/=p;
      end;
    Writeln('Результат: ',r)
    end
end.

Написать программу на языке pascalabc, которая умеет выполнять арифметические действия с 5 разными ч
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?