В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
2003nur
2003nur
04.06.2020 00:08 •  Информатика

Написать программу (с program. var и тд) дано семизначное число. найти сумму,произведение и среднее арифметическое этих цифр

Ответ:
AnnaVag8912
AnnaVag8912
07.10.2020 23:01
Var a,b,i,s,p:integer;
begin
readln(a);
s:=0; p:=1;
for i:=1 to 7 do
 begin
 b:=a mod 10;
 s:=s+b;
 p:=p*b;
 a:=a div 10;
 end;
writeln('s = ',s,' p = ',p,' sr = ',s/7:5:2);
end.

Пример:
1389546
s = 36 p = 25920 sr = 5.14
0,0(0 оценок)
Ответ:
tdemon
tdemon
07.10.2020 23:01
Программа прикреплена в приложении

Примеры:

Введите семизначное число: 4564564
Среднее арифметическое цифр числа: 4.85714

Введите семизначное число: 6535684
Среднее арифметическое цифр числа: 5.29

Введите семизначное число: 6563258
Среднее арифметическое цифр числа: 5.00
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?