В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ttleuberlin
ttleuberlin
08.01.2020 11:07 •  Информатика

Составить программу которая считывает целое число. если оно чётное и положительно увеличить его в два раз , в противном случае увеличить в 10 раз.

Ответ:
Rianariana2002
Rianariana2002
26.08.2020 22:29
C#:
    class Program
    {
        static void Main(string[] args)
        {
            int a;
            a = Convert.ToInt32(Console.ReadLine());
            if (a % 2 == 0)
            {
                a *= 2;
            }
            else
            {
                a *= 10;
            }
            Console.WriteLine(a);

            Console.ReadLine();
        }
    }

Pascal:

program n;
var
a: integer;
begin
readln(a);
if a mod 2 = 0 then
a *= 2
else
a *= 10;
writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?