В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ma4oMatoy
Ma4oMatoy
17.05.2021 03:29 •  Информатика

Написать программу которая формирует массив из 10 случайных чисел в диапазоне от 1 до 10 и вычисляет произведения элементов массива с нечетными значениями.
на экран выводится исходный массив, массив с нечетными значениями и произведение.
pascal

Ответ:
snezhanashikolai
snezhanashikolai
07.10.2020 21:49

program fantscrin;

 const n = 10;

 var a: array [1..n] of integer;

        i,s:integer;

Begin

 for i:=1 to n do

   a[i]:= random(11)+1;

 for i:=1 to n do

   write(a[i], '  ');

 p:=1;

 for i:=1 to n do

   if (i mod 2 <> 0) then

                           begin

                                p:=p*a[i];

                                write(a[i], '  ');

                            end;

 writeln('');

 writeln('Произведение = ',p);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?