В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Пепечка
Пепечка
08.12.2022 06:17 •  Информатика

Составить программу в с++: создать функцию square (x) нахождение его площади квадрата и функцию maxi (x, y) нахождение наибольшего из двух значений. дано сторону квадрата. составить программу с использованием функции square и maxi, которая для двух квадратов, будет находить тот, площадь которого больше и выводить значение большей площади на экран.

Ответ:
Hellwood12
Hellwood12
07.10.2020 21:49
#include <iostream>
using namespace std;

double square(double x) {
   return x*x;
}

double maxi(double x, double y) {
  if (x>y)
     return x;
  else
     return y;
}

int main() {
   double a1,a2,s1,s2;
   cin >> a1 >> a2;
   cout << "s=" << maxi(square(a1),square(a2)) << endl;
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?