В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lolabrikoslol
lolabrikoslol
01.04.2022 02:21 •  Информатика

Синформатикой, написать программу в паскале,которая по координатам 2х введенных точек определяла бы четверть координатной плоскости,где они находятся(можно сделать через 4 if),а также длину отрезка между ними(используя функцию sqrt и формулу длины отрезка)

Ответ:
QuietW
QuietW
07.10.2020 21:37
 uses crt;
 var
    x,y: real;begin 
clrscr;
    write ('x = '); read (x);
    write ('y = '); readln (y);    if (x > 0) and (y > 0) then
        writeln ('Номер четверти координатной плоскости:I')
    else
        if (x < 0) and (y > 0) then
            writeln ('Номер четверти координатной плоскости:II')
        else
            if (x < 0) and (y < 0) then
                writeln ('Номер четверти координатной плоскости:III')
            else
                if (x > 0) and (y < 0) then
                    writeln ('Номер четверти координатной плоскости:IV')
                else
                if (x>0)or(x<0) and (y=0) then    writeln ('-. Точка лежит на оси. X')
                                   else
                if (y>0)or(y<0) and (x=0) then    writeln ('-. Точка лежит на оси. Y')
                                   else writeln ('-. Точка лежит в центре.');readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?