Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
haha1
05.11.2020 04:02 •
Информатика
Дан двумерный массив целых чисел. выяснить: а) имеется ли в нем положительный элемент; б) имеется ли в нем элемент, последняя цифра которого равна а. , надо!
Ответ:
dontgiveupDGU
07.10.2020 21:23
#include "stdafx.h"#include <iostream>#include <windows.h>#include <ctime>using namespace std;int main(){ SetConsoleCP(1251); SetConsoleOutputCP(1251); srand(time(0)); int core[5][5]; int t, n; bool cf, p; for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { t = 0 + rand() % 2; core[i][j] = 0 + rand() % 20; if (t == 1) { core[i][j] = -core[i][j]; } cout << " " << core[i][j] << " "; } cout << endl; } cout << endl; cout << "Последняя цифра " << endl; cin >> n; for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { if (core[i][j] % 10 == n) { cf = true; } if (core[i][j] > 0) { p = true; } } } if (cf == true) { cout << "Число, оканчивающееся на цифру " << n << " есть"<< endl; } else { cout << "Числа, оканчивающегося на цифру " << n << " нет" << endl; } if (p == true) { cout << "Положительное число есть" << endl; } else { cout << "Положительных чисел нет " << endl; }}
0,0
(0 оценок)
Популярные вопросы: Информатика
evgen16112000
12.10.2022 02:24
Рисунок размером 128 на 64 пикселя занимает в памяти 4096 байт.найдите максимально возможное количество цветов в палитре изображения....
htntjtjt
20.11.2020 13:09
B) книга состоит из 5 глав, причем число страниц в третьей главе в 2 раза меньше, а в пятой в 2 раза больше, чем в первой. объем второй и четвертой главы составляет...
Айlosss
20.11.2020 13:09
A)вы узнали, что ваш друг живет на 5 этаже 16-этажного дома во 2 подъезде. всего в доме 8 подъездов. какое количество информации вы получили?...
afkds
15.05.2022 21:20
25 ) ,придумайте какой-нибудь ребус или кроссворд(какое-нибудь интересное ) на тему оперативная память компьютера заранее...
GagarinPSK
29.12.2020 03:21
Оприделите информационный объём сообщения если каждый символ 4бит число 13-нечётное и простое...
galinadik84
01.08.2021 04:17
Укажите, как называется процесс, использующий совокупность средств и методов сбора, обработки и передачи данных для получения информации нового качества о состоянии...
Logutova
01.08.2021 04:17
1101101₂+101110₂= 101₂+110011₂= 11010,01₂+1011,101₂= (двоичная система счисления) памятка: 0+0=10 0+1=1 1+0=1 1+1=10...
bogdanpavlovi
17.05.2021 06:07
Втечение года в солнечном городе облачных дней было на x дня больше, чем дней с дождем или снегом, и на y меньше чем солнечных дней. сколько было солнечных дней...
копытирина
17.05.2021 06:07
Дано трехзначное число. определить, является ли сумма его цифр кратна 3 и 5. необходимо написать программу ,которая будет это вычислять.на c++ и на pascal...
Смамойспал123
17.05.2021 06:07
Найти ошибку в программе program task5; var v: string; ch: integer; begin writeln( введите число ); readln (ch); case ch of 1: v: = ( один ); 2: v: = ( два ); 3:...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?