В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
777кошка777
777кошка777
01.01.2021 09:53 •  Информатика

Составьте программу вычисления выражения (разными применяя каждый из операторов while,repeat,for) a^p, где p - целое число. pascal / надо.

Ответ:
lllviktorialll
lllviktorialll
04.08.2020 10:00
1)Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  while i<p do
  begin
    c:=c * a;
    inc(i);
  end;
  writeln(c);
  readln;
end.

2) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  repeat
    c:=c * a;
    inc(i);
  until i=p;
  writeln(c);
  readln;
end.

3) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1;
  for i:=1 to p do
    c:=c * a;
  writeln(c);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?