В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Policehig
Policehig
08.05.2023 14:16 •  Информатика

Синформатикой,. (составить программу pascal) 1) массив на 10 элементов, заменить случайными числами из диапазона от 0 до 15. найти кол-во элементов равных max. 2) найти в массиве на 20 элементов, заполненных случайными числами {0; 150}. max и min. и поменять

Ответ:
TAMADA123123
TAMADA123123
07.10.2020 20:55
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,0,15); a.Println;
  var max:=a.Max;
  Write('Максимальный элемент ',max);
  Write(', элементов, равных ему - ',a.Where(x->x=max).Count-1)
end.

Пример
7 15 8 1 15 13 6 15 5 11
Максимальный элемент 15, элементов, равных ему - 2



begin
  var a:=ArrRandom(20,0,150); a.Println;
  var (imin,imax):=(a.IndexMin,a.IndexMax);
  Writeln('Минимальный элемент ',a[imin],', максимальный ',a[imax]);
  Swap(a[imin],a[imax]); a.Println
end.

Пример
131 123 150 38 146 59 69 12 66 44 130 138 29 32 122 25 134 6 143 127
Минимальный элемент 6, максимальный 150
131 123 6 38 146 59 69 12 66 44 130 138 29 32 122 25 134 150 143 127
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?