Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Элеонора335564
25.08.2020 08:09 •
Информатика
Составить программу вычисления суммы ряда s: =1+2+3+4+5+6
Ответ:
alonedango
07.10.2020 20:45
Program summa;
uses crt;
Var s, i, n:integer;
begin
Write('n=') ;readln(n) ;
s:=1; write('s=1') ;
For i:=2 to n do
Begin
s:=s+i;
Write('+', i) ;
End;
Write('=', s) ;
readln;
end.
0,0
(0 оценок)
Ответ:
azzzzzi208
07.10.2020 20:45
1. Самый незатейливый вариант, выдающий значение суммы 21
begin
Writeln(1+2+3+4+5+6)
end.
2. Типовой "школьный вариант"
var
i,s:integer;
begin
s:=0;
for i:=1 to 6 do s:=s+i;
Writeln(s)
end.
3. Современный вариант, немного покороче
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
1.To(6).Sum.Println
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
775svetik
22.12.2020 01:01
20 . кто шарит в с++? как отсортировать двумерный массив как нибудь пооптимальней? буду ....
lolologhka
14.06.2022 04:49
1. Обговоріть, які події в запропонованому списку можна подати алгоритмами із вкладеними розгалуженнями:а) проїзд автомобіля через перехрестя, яке регулю-ється світлофором;б)...
Мальчик123870
25.12.2020 23:58
Всистеме счисления с некоторым основанием число 12 записывается в виде 110. укажите это основание....
ghosthog
25.12.2020 23:58
Створіть проект для обчислення суми цифр заданого натурального числа, кількість цифр якого не більше 9...
Jamilya28
21.02.2020 22:39
Напишіть 3 речення з дієсловом ‘go’ та герундієм.Зразок: I go running every day.2) Write 4 sentences with phrases: ‘need to + verb’; ‘want to + verb’; ‘advise somebody to +...
Юля5451
21.02.2020 22:39
. Setzen Sie richtig ein: (Напиши дієслово у правильній формі) 1. Die Wohnung ___ aus zwei Zimmern (bestehen) 2. Alle Fenster ___ nach dem Süden (gehen) 3. Die Wohnung ___ allen...
Бегимотик002
29.04.2022 17:20
Какое число уменьшится на треть, если его перевернуть....
kudryavcevanat
28.03.2020 05:24
Які з рівнянь є біквадратними? 3х2 – 2х4 – 1 = 0 3х3 + 4х2 – 7 = 0 –х4 + х2 + 10 = 0 х2 – 2х + 6 = 0...
ЭвелинаEvelina
28.03.2020 05:24
Во под номером 5 с обьяснением...
наифа
02.03.2020 09:12
Подскажите где скачать книгу манга! Японское руководство по рисованию комиксов ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
Var s, i, n:integer;
begin
Write('n=') ;readln(n) ;
s:=1; write('s=1') ;
For i:=2 to n do
Begin
s:=s+i;
Write('+', i) ;
End;
Write('=', s) ;
readln;
end.
begin
Writeln(1+2+3+4+5+6)
end.
2. Типовой "школьный вариант"
var
i,s:integer;
begin
s:=0;
for i:=1 to 6 do s:=s+i;
Writeln(s)
end.
3. Современный вариант, немного покороче
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
1.To(6).Sum.Println
end.