В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Xro8
Xro8
18.02.2023 00:35 •  Информатика

Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матрицы

Ответ:
Gerty21
Gerty21
07.10.2020 20:17
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(m,n,-99,99); a.Println(4); Writeln;
  Writeln('Max=',a.ElementsByRow.Max)
end.

Пример
Количество строк и столбцов в матрице: 5 8
*** Исходная матрица ***
  37  27  -8 -40 -85 -36  62  90
 -60 -14 -18   0 -50  77 -19 -36
  14 -98 -80  81  -8  83  84  26
 -65  74  12 -77 -84  -4 -51 -93
  94  34  45  23 -53 -55  55 -45

Max=94
0,0(0 оценок)
Ответ:
rudenkonn57
rudenkonn57
07.10.2020 20:17
Создается матрица 10х10, заполняется случайными числами от 0 до 100, выводит исходную матрицу и Max элемент.
Напишите программу, которая заполняет матрицу случайными числами и находит максимальный элемент матр
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?