Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
MorohaHaimura
28.01.2023 11:06 •
Информатика
Задан массив a[1..17]. составьте программу, которая выводит индексы тех элементов, значения которых равны нулю.
Ответ:
Alexader2352
07.10.2020 20:23
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(17,-5,5); a.Println;
var s:=a.IndexesOf(t->t=0);
if s.Count>0 then s.Select(t->t+1).Println
else Writeln('нет нулей')
end.
Пример
-3 -5 0 0 1 0 -5 2 1 -5 2 -1 2 -5 0 -5 2
3 4 6 15
0,0
(0 оценок)
Ответ:
нмрмгштщ
07.10.2020 20:23
Var
a:array[1..17] of integer;
i:integer;
begin
for i:= 1 to 17 do
begin
read(a[i]);
if a[i] = 0 then
Write(i, ' ');
end;
end.
пример:
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
1 11
0,0
(0 оценок)
Популярные вопросы: Информатика
000конфета000
14.01.2020 21:54
Информатика 5 классс умоляю...
DastyMilk
28.06.2020 16:20
Что имеет поле базы данных? -ширину -тип -длину -имя -площадь -высоту...
азаззазазаазз
14.07.2020 02:22
41. Световое табло состоит из лампочек, каждая из которых может находиться в двух состояниях: 4 включено «выключено». Какое наименьшее количество должно находиться на табло, чтобы...
Германкорпорация
21.11.2020 07:39
1)Для наглядного представления изменения температуры воздуха в течение месяца следует использовать а) круговую диаграмму б) график в) столбчатую диаграмму г) ярусную диаграмму2)Информацию,...
Nika31303
25.07.2020 07:41
(python) нужно сделать домик как на картинке, заранее хочу поблагодарить за ....
djodanosu7n8
08.12.2021 01:23
Розкажіть про суперників Івана Сили з якими відбулися поєдинки. Чим закінчуються двобої силачів...
ритттт
05.05.2021 12:44
Put the verbs in brackets into the past simple or the present perfect. 1 A: When did you.move (you/move) house, David? B: Three days ago but I 4 A: How long (you/live) in America?...
Elka6677
14.10.2020 17:03
Косметическая фабрика отправила в магазин 2400 упоковок мыла.Треть всех упаковок мыла-детское.Хозяйственного мыла было 735 упаковок,а остальные упаковки-душистое мыло для рук.Сколько...
bulatnurtdinov
14.10.2020 17:03
Выбери вещества, вступающие в реакции с высшим оксидом химического элемента, в атоме которого три электронных слоя, а на внешнем уровне находятся шесть электронов: Cs2O HNO3 H2O AgCl...
emin19
31.01.2022 16:38
Підготувати твори на тему МАЙСТЕР ВЕСЕЛОГО ЦЕХУ іть...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(17,-5,5); a.Println;
var s:=a.IndexesOf(t->t=0);
if s.Count>0 then s.Select(t->t+1).Println
else Writeln('нет нулей')
end.
Пример
-3 -5 0 0 1 0 -5 2 1 -5 2 -1 2 -5 0 -5 2
3 4 6 15
a:array[1..17] of integer;
i:integer;
begin
for i:= 1 to 17 do
begin
read(a[i]);
if a[i] = 0 then
Write(i, ' ');
end;
end.
пример:
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
1 11