В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу: на вход программы поступает неизвестное количество чисел целых, ввод заканчивается нулём. найти максимальное из введённых чётных чисел. python.

Ответ:
krasatulea83
krasatulea83
07.10.2020 20:15

list_number = []    # Создали список, сюда заносим числа.

number = int(input())   # Вводим число

while number != 0:    # Проверяем на равенство число нулю

   list_number.append(number)    # Добавляем число в список

   number = int(input())   # Вводим след.число

if list_number: # Если список не пуст

   # Фильтруем список(возвращаем список только с четными числами) и выбираем максимальное

   result_number = max(list(filter(lambda x: x % 2 == 0, list_number)))    

   print("Result: {0}".format(result_number))  # Выводим результат

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?