В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ппр49
ппр49
27.06.2020 12:47 •  Информатика

Задайте число в интервале от 1 до 100. составьте программу (паскаль), которая: -умножает это число на себя -складывает результат умножения с удвоенным исходным числом -делит полученную сумму на исходное число -вычитает из результата деления исходное число -выводит на экран окончательный результат

Ответ:
lebswetl
lebswetl
16.08.2020 17:03
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите число от 1 до 100:');
  Writeln('Получаем ',((n*n+2*n) div n)-n)
end.

Пример
Введите число от 1 до 100: 77
Получаем 2

Замечание.
Сделаем преобразование.
(n*n+2*n)/n-n = n(n+2)/n-n = n+2-n = 2
Всегда будет получаться результат 2.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?