Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
angelinaardasheva
03.04.2023 13:21 •
Информатика
Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и второго, если оно больше второго! на языке паскаль
Ответ:
Danefremov03
07.10.2020 19:59
Var
a,b,c:real;
begin
Readln(a,b,c);
if a > c then a:= a/2;
if c > b then c:= c-b;
Writeln(a, ' ', b, ' ', c);
end.
Пример:
4 2 3
2 2 1
0,0
(0 оценок)
Ответ:
pudovkinao
07.10.2020 19:59
Var
x,y,z:real;
begin
write('Введите 1 число: ');
readln(x);
write('Введите 2 число: ');
readln(y);
write('Введите 3 число: ');
readln(z);
if x>z then x:=x/2;
if z>y then z:=z-y;
writeln('1 число: ',x);
writeln('2 число: ',y);
writeln('3 число: ',z);
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
anna666666666666
26.02.2020 19:59
Как искусство связано с производством фейков и фейковых новостей?...
шкода4
01.08.2020 04:55
Человек, оценивающий потребности пользователей в применении компьютера, а также проектирующий информационные системы, которые соответствуют этим потребностям:...
егор1465
20.11.2022 07:11
Татарин отгонял снял жилина с лошади и кликнул работника это описание или повествование...
kburuncenco307
20.11.2022 07:11
Менің сиқырлы етік болса ертегі жазу керек...
ЕlyaBr
20.11.2022 07:11
Длина прямоугольника 40 см а его ширина в 2 раза меньше. чему равен периметр этого прямоугольника...
vladcjdyte
20.11.2022 07:11
Реши вычисли и запиши ответ . в первом мешке 5 кг.230 г.морковки .во втором мешке на 850 г. морковки больше, чем в первом. всю морковь из двух мешков переложили...
viktoriy2009
20.11.2022 07:11
Ккакой группе животных относится медведь земноводные,пресмыкающиеся,млекопитающие. к какой группе животных по типу питания относится медведь...
RABOTAY
20.11.2022 07:11
Разложить многочлены на множители a) 16a^2+56ab+49b^2 b) -c^2-4cd-4d^2 c) x^2-9x+14...
dimao2003
20.11.2022 07:11
Чем полезен в разрешении конфликта посредник...
anastasiyachevh
20.11.2022 07:11
Найдете производную функции f(x)=√7+14x-5^6...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a,b,c:real;
begin
Readln(a,b,c);
if a > c then a:= a/2;
if c > b then c:= c-b;
Writeln(a, ' ', b, ' ', c);
end.
Пример:
4 2 3
2 2 1
x,y,z:real;
begin
write('Введите 1 число: ');
readln(x);
write('Введите 2 число: ');
readln(y);
write('Введите 3 число: ');
readln(z);
if x>z then x:=x/2;
if z>y then z:=z-y;
writeln('1 число: ',x);
writeln('2 число: ',y);
writeln('3 число: ',z);
readln;
end.