В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Лейля16
Лейля16
09.09.2021 14:45 •  Информатика

Написать программу на паскале к
ученик 9 класса к уроку должен выучить наизусть три первые строфы первой главы романа а, с. пушкина «евгений онегин», содержащие 42 строки. сколько ему потребуется времени на выполнение этого , если первую строку он может запомнить за 5 секунд, а на запоминание каждой следующей строки ему требуется времени на 2 секунды больше, чем на запоминание предыдущей строки?

Ответ:
Andrey785
Andrey785
07.10.2020 19:40

Var str , time, thtime: integer;

Begin

str := 42;

thtime := 5;

While str>0 Do

Begin

str := str-1;

time := thtime+time;

thtime := thtime+2;

End;

write(time,' секунд');

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?