Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Динара22235
12.04.2023 19:34 •
Информатика
Составить программу в паскале! известна стоимость 1 кг конфет, печенья, яблок. найти стоимость всей покупки, если купили х кг конфет, y кг печенья и z кг яблок.
Ответ:
ablyaev98
07.10.2020 19:44
Var
k,p,i,s,x,y,z:real;
begin
write('Стоимость килограмма конфет: ');
readln(k);
write('Стоимость килограмма печенья: ');
readln(p);
write('Стоимость килограмма яблок: ');
readln(i);
write('Купили конфет: ');
readln(x);
write('Купили печенья: ');
readln(y);
write('Купили яблок: ');
readln(z);
s:=x*k+y*p+z*i;
write('Потратили всего: ',s);
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
shulyakovatati
30.08.2022 18:14
В электронной таблице значение формулы =СРЗНАЧ(В2:D2) равно 6. Чему равно значение ячейки Е2, если значение формулы =СУММ(В2:Е2) равно 20?...
pashnina379
11.10.2022 06:08
мне с информатикой алгоритмы с ветвлением...
KarinaKOSMOS
10.05.2022 22:16
Какое количество целых музыкальных композиций длительностью 2 минуты, кодированием звука с частотой дискретизации 24 кГц и глубиной кодирования звука 16 бит, без дополнительного...
milka0121
31.05.2023 11:41
Запишите число пятью различными 1257,952 и 873614,8...
risik1205super
02.08.2022 16:59
Как разработать программу на языке Pascal, используя массивы?...
Данил67854
01.10.2022 15:48
3. Сравнить: А) 64 байта и Кбайта; 256 B) 2* Мбайт и 128 Кбайт; Б) 1 Кбайт и 223 бит; г) на Кбайта и 64 бит. 128...
anjelanartokova
11.05.2022 15:12
Сочинение на тему описание книги. напри мер брат подарил мне роман жюля верна удивительные приключения дядюшки антифера. эта книга в синем прочном переплете. и так далее...
Azadamurshaeva
05.11.2021 04:42
Зточки до прямої проведено дві похилі, довжини яких відповіднодорівнюють 5см i 7 см. знайдіть відстань від даної точки до цієї прямої, якщо одна з проекцій похилих на 4...
пага3
11.05.2022 15:12
Вычислите а) 3/4 - ( 1 1/3 - 1 1/ 6 )...
Oks111111
30.08.2021 00:04
After the game was over tom went out to the street. вместо точек вставьте предлог....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
k,p,i,s,x,y,z:real;
begin
write('Стоимость килограмма конфет: ');
readln(k);
write('Стоимость килограмма печенья: ');
readln(p);
write('Стоимость килограмма яблок: ');
readln(i);
write('Купили конфет: ');
readln(x);
write('Купили печенья: ');
readln(y);
write('Купили яблок: ');
readln(z);
s:=x*k+y*p+z*i;
write('Потратили всего: ',s);
readln;
end.