Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
slava02555
11.03.2021 04:45 •
Информатика
Требуеться написать программу, при выполнении которой с клавиатуры считывается натуральное число n, и выводится минимальная цифра этого числа
Ответ:
Anytohka0cosmos
07.10.2020 19:52
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
long long int N;
short int MinDig = 10;
cout << "N = ";
cin >> N;
while (N != 0) {
if (N % 10 < MinDig) MinDig = N % 10;
N /= 10;
}
cout << "Наименьшая цифра = " << MinDig << endl;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Нашли
10.05.2022 06:16
Сколько цифр 1 в двоичном представлении десятичного числа 18?...
mgam56
19.01.2022 05:22
Информация на каких носителях может быть утеряна(перестать считываться), если случайно прикоснуться рукой к поверхности носителя?...
ilyadengin
19.01.2022 05:22
Напишите наиболее короткие вычисления выражений: x^45, x^21, x^17, x^11 в выражениях можно использовать лишь сложение, вычитание, умножение. не использовать power,...
Соня8912
19.01.2022 05:22
Какое логическое выражение равносильно выражению: не(c→(a+b))...
marine25
22.10.2020 08:03
Какое устройство компьютера моделирует мышление человека?...
KotyaFila
17.06.2021 15:33
Какой минимальный объём видеопамяти необходим для работы монитора в режиме 640х480 и палитрой из 2 цветов? Выберите один ответ:a. 37,5 Кб.b. 65,5 Кб.c. 80 Кб....
MaksandSany
22.09.2020 05:39
Составить словесный алгоритм для решения задачи: В первый день турист проехал х километров, во второй день – на 10 километров больше, чем в первый день, а в третий...
ShkolnikN15
29.11.2020 18:34
Сколько времени потребуется для передачи документа объёмом 4 Мбайт с одного компьютера на другой, если средняя скорость передачи данных по каналу связи составляет...
TKluykova
11.09.2020 00:36
Требуется определить, является ли данный год високосным. (Год является високосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400.) Входные...
miirko777
26.10.2020 19:47
На які три види поділяється копютер...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
long long int N;
short int MinDig = 10;
cout << "N = ";
cin >> N;
while (N != 0) {
if (N % 10 < MinDig) MinDig = N % 10;
N /= 10;
}
cout << "Наименьшая цифра = " << MinDig << endl;
system("pause");
}