В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
liza04543
liza04543
07.12.2020 21:15 •  Информатика

Написать программу : в последовательности натуральных чисел найти сумму и кол-во дву значных чисел начинающихся на 2 program - pascal abc

Ответ:
vitalia4420
vitalia4420
07.10.2020 18:56
Program Rick_and_Morty;
var x,y,i:integer;
var a:array [1..9999] of integer;

Begin
y:=0;
write('введите количество чисел (макс 9999): ');
readln (x);

write('Масив: ');

for i:=1 to x do
begin
a[i]:=random(89)+10;
write(a[i],', ');
end;

writeln('');

for i:=1 to x do
begin

if (a[i] div 10 =2) then
begin
y:=a[i]+y;
writeln('Подходящее число:',a[i],' сумма =',y );
end;

end;

writeln('конец');
end.
Написать программу : в последовательности натуральных чисел найти сумму и кол-во дву значных чисел н
Написать программу : в последовательности натуральных чисел найти сумму и кол-во дву значных чисел н
0,0(0 оценок)
Ответ:
anka4323
anka4323
07.10.2020 18:56
var
i,n,cnt,tmp,sum, last:integer;
a:array [1..9999] of integer;

Begin
Writeln('Введите кол-во элементов');
Readln(n);
Writeln('Введите последовательность -> ');
for i:= 1 to n do
  read(a[i]);
writeln();

for i:=1 to n do
  begin
    tmp:= a[i];
      while tmp > 0 do
        begin
          last:=tmp mod 10;
          tmp:= tmp div 10;
        end;
  if last = 2 then
    begin
      cnt:= cnt + 1;
      sum:= sum + a[i];
    end;
  end;

Writeln('Всего элементов: ', cnt);
Writeln('Сумма равна ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?